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Downloading and Installing R and RStudio (for PC/Mac)

If you have an Ubuntu operating system (OS) or any other OS aside from a PC/Mac, then you must love
Linux and/or working in the terminal. That’s impressive and you most likely can skip ahead to the section
titled ‘First Session’

In order to download R, please see their website. The website appears underdeveloped but you’re at the right
spot. Under the heading Download and Install R, you’ll see the links to download R for your respective
OS.

In order to download RStudio (a fancy graphical user interface [GUI]), please see their website. This website
is not underdeveloped but rather crisp. Moving on, under the heading Installers for ALL Platforms,
you’ll see the links to download RStudio for your respective OS. For your respective OS, it should be the
first or the second link.

The best explanation to give as to why you need both is this: RStudio is the fancy and friendly GUI that
keeps you sane and organized as well as providing an inviting workplace, hence the very point of a GUI. You
CANNOT use RStudio without R. R is what is under the hood, the engine per se, and RStudio is the
interior and exterior of your car/truck/Italian moped. I am ‘automobile illiterate’ so please don’t make me
continue with this metaphor.

Launching and Exiting RStudio

Launching RStudio For PC users, please do the following: Start > All Programs > RStudio

For Mac users, please do the following: Applications > RStudio; or Click on the RStudio icon shortcut on
your dock; or In spotlight search (Cmd + Spacebar; or the magnifying glass in the upper right corner), enter
RStudio and press return.

Once in awhile, you will be asked to update RStudio. Please do so.

Exiting RStudio From the toolbar at the top, at the far left: Click RStudio. From the drop down menu,
click Quit RStudio. For PC, the shortcut is [insert shortcut here]. For Macs, the shortcut is Cmd + Q.

Toolbar and Windows

Upon starting RStudio, it will be intimidating, but do not fear, your loyal TA is here. There is a lot to
grasp but getting your feet wet is the best way to progress with R.
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Toolbar There are many options present in the toolbar, but for now, there are 4 commands we will
highlight.

The first command is under the following: File > New File From there, one should see R Script. Similar to
Stata’s do-file, a script allows you to write notes, commands, and anything else one may desire for a session.

The second command is near the first: File > New Project From there, a box will pop up, asking you to
Create a Project From. Choose the first option, New Directory, followed by Empty Directory, and give your
project a name. For the sake of this class, name your project by the respective week of the class or the session
number.

The third command is under the following: Tools > Import Dataset > From Text File. . . /From Web URL. . .
Uploading the data can be painful and if it takes you longer than 10 minutes, please consult me or any online
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help forums. Unless one is scraping data from Twitter or some other complex method, it should be relatively
easy. If need be, copy and paste into excel and save as a comma separated value (CSV) file and then import.
You’ll also notice the shortcut symbol for Import Dataset, a sheet and an arrow.

The fourth command is under the following: Tools > Global Options For now, Appearance and Pane Layout
are readily available to change the appearance of RStudio, such as the size of the text, the color scheme of
the script and code, and various other options.
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RStudio Layout Upon starting RStudio, you will see this similar layout (enter image). One half of the
computer monitor is devoted to the source code, scripts, and the console, which runs the code. As for the
other half of the monitor, you will see an environment where objects are stored, such as datasets and functions
as well as the name of your files, plots, packages, and other tabs that you may explore.

First Session

Key to Colors The default color theme for R is TextMate. If you recall, you may change the theme under
Tools > Global Options > Appearances.
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Green- These are comments. In R, commands that begin with a number sign/pound sign/hashtag are
comments.

Blue- These are commands. Each command begins with an angle bracket ( > ).

Black- This is R output. Compare it with the output you get.

Preliminaries (working directory, start log, input data) In order to start or track a log, there is
something called git. You may have heard of GitHub. We’ll talk about that at a later time. As for now,
simply start a new file or script to save your notes and commands.

Your working directory is the default location to save and generate files, datasets, etc. Here are two helpful
commands.

# The following command displays your current working directory.
getwd(...) # default location will be where project is specified
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# The following command changes your current working directory to whatever you set it to.
setwd(...) # this is a pain to write out but it'll become useful

R has the ability to import data from a web url as well as a text file (CSV, comma delimited or tab files,
etc.). R contains packages, a unique set of commands and datasets, which are developed by users from all
over the world. Before uploading a package into your library, you must install the respective package as
such: “install.packages(”package name“)”. In order to upload the same dataset from the Stata handout, the
following commands will ensue.

library(foreign) # a package that translates Stata, SAS, or SPSS data into R

stata <- "http://www.pauldickman.com/survival/ivf.dta" # Web URL, note '.../ivf.dta'

ivf <- read.dta(file = stata) # ivf is the name of the dataset whereas read.dta is the command

As I’m sure you’ve noticed, the symbol ‘<-’ is how objects are stored in R.

View Data Structure Here are commands to view the structure of the data.

str(ivf) # the structure of dataset ivf

## 'data.frame': 641 obs. of 6 variables:
## $ id : num 1 2 3 4 5 6 7 8 9 10 ...
## $ matage : int 33 34 34 30 35 37 31 31 33 33 ...
## $ hyp : int 0 0 0 0 0 0 0 1 1 0 ...
## $ gestwks: num 37.7 39.2 35.7 39.3 38.4 ...
## $ sex : Factor w/ 2 levels "male","female": 2 2 2 1 2 1 1 2 1 2 ...
## $ bweight: int 2410 2977 2100 3270 2620 3260 3750 1450 3200 3675 ...
## - attr(*, "datalabel")= chr "In Vitro Fertilization data"
## - attr(*, "time.stamp")= chr "27 Aug 2001 13:11"
## - attr(*, "formats")= chr "%9.0g" "%8.0g" "%8.0g" "%9.0g" ...
## - attr(*, "types")= int 102 98 98 102 98 105
## - attr(*, "val.labels")= chr "" "" "" "" ...
## - attr(*, "var.labels")= chr "identity number" "maternal age (years)" "hypertension (1=yes, 0=no)" "gestational age (weeks)" ...
## - attr(*, "version")= int 7
## - attr(*, "label.table")=List of 1
## ..$ sex: Named int 1 2
## .. ..- attr(*, "names")= chr "male" "female"

dim(ivf) # displays the dimensions of dataset ivf

## [1] 641 6

names(ivf) # displays variable/column names

## [1] "id" "matage" "hyp" "gestwks" "sex" "bweight"

summary(ivf) # summary of ivf
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## id matage hyp gestwks sex
## Min. : 1 Min. :23 Min. :0.000 Min. :24.7 male :326
## 1st Qu.:161 1st Qu.:31 1st Qu.:0.000 1st Qu.:38.0 female:315
## Median :321 Median :34 Median :0.000 Median :39.1
## Mean :321 Mean :34 Mean :0.139 Mean :38.7
## 3rd Qu.:481 3rd Qu.:37 3rd Qu.:0.000 3rd Qu.:40.1
## Max. :641 Max. :43 Max. :1.000 Max. :42.4
## NA's :2
## bweight
## Min. : 630
## 1st Qu.:2850
## Median :3200
## Mean :3129
## 3rd Qu.:3550
## Max. :4650
##

summary(ivf$sex) # factoral summary of categorical variable sex

## male female
## 326 315

summary(ivf$bweight) # numerical summary of variable bweight

## Min. 1st Qu. Median Mean 3rd Qu. Max.
## 630 2850 3200 3130 3550 4650

Examine Data The simplest way to view your data is with the following command:

View(ivf) # will display a table in the same pane as scripts

To view snippets of your data, implement the following commands:

head(ivf) # default display is 6 rows

## id matage hyp gestwks sex bweight
## 1 1 33 0 37.74 female 2410
## 2 2 34 0 39.15 female 2977
## 3 3 34 0 35.72 female 2100
## 4 4 30 0 39.29 male 3270
## 5 5 35 0 38.38 female 2620
## 6 6 37 0 37.86 male 3260

tail(ivf, 10) # displays tail end of ivf, more specifically, the last 10 rows

## id matage hyp gestwks sex bweight
## 632 632 31 0 39.66 female 3940
## 633 633 33 0 39.37 female 3545
## 634 634 35 0 39.86 female 3320
## 635 635 33 0 38.17 male 3350
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## 636 636 34 0 41.15 male 2972
## 637 637 28 0 38.58 female 2850
## 638 638 38 1 38.44 male 3182
## 639 639 26 0 38.94 female 3048
## 640 640 31 0 40.43 female 3183
## 641 641 31 0 38.15 male 2920

Lastly, you may view specific rows and columns as such:

ivf[10, 6] # 10th row, 6th column

ivf[325, ] # 325th row, all columns

ivf[ , 4] # all 641 rows, 4th column

Single Variable Description In R, if one would like to highlight a single variable, implement the following
syntax:

mean(ivf$bweight) # dataset followed by '$' followed by variable name

## [1] 3129

If one would like to explore a single variable, here are some commands:

min(ivf$matage); max(ivf$matage) # similar to SAS, you may implement the a semi-colon to separate commands on line

## [1] 23

## [1] 43

range(ivf$gestwks) # range

## [1] 24.69 42.35

mean(ivf$gestwks); median(ivf$gestwks) # mean and median

## [1] 38.69

## [1] 39.15

sd(ivf$gestwks) # standard deviation

## [1] 2.33

table(ivf$sex) # frequency

##
## male female
## 326 315
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The base graphics in R are really just that, basic, but in the coming weeks, new graphical packages will be
explained and implemented. For now, here are a few commands:

hist(ivf$bweight) # histogram

Histogram of ivf$bweight
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stem(ivf$bweight) # stem and leaf plot...not sure if you'll need to ever use this

##
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## The decimal point is 2 digit(s) to the right of the |
##
## 6 | 301
## 8 | 3628
## 10 | 0206
## 12 | 0123
## 14 | 035024569
## 16 | 17745689
## 18 | 02792456
## 20 | 00880001357
## 22 | 0225689223466679
## 24 | 011122235680000114455555688899
## 26 | 000011122222345556678990000000222223345557777788
## 28 | 00000123344445556667788999990000011111222222333344445556666677778888
## 30 | 00000000000111222333444444444555666667788888889900000000000001222222+21
## 32 | 00000000122223333333444444566666666777778888999999900000000112222333+23
## 34 | 00000001222234445555566666666677888999000000011222444445555556666667+1
## 36 | 0000000011222233344455566668888899000001122222333444555667777788899
## 38 | 00011122245667889913344444577888
## 40 | 02334466892234488
## 42 | 0002389011234
## 44 | 22350025
## 46 | 5

Two Variable Descriptives Here are a few commands for two variable descriptives:

table(ivf$sex, ivf$hyp) # 2-way table

##
## 0 1
## male 273 52
## female 277 37

table(ivf$sex, ivf$hyp)/641 # R does not have a good way to display percentages so it must be done manually

##
## 0 1
## male 0.42590 0.08112
## female 0.43214 0.05772

And some graphical commands for two variable descriptives:

boxplot(ivf$gestwks ~ ivf$sex) # one continuous variable by one descriptive variable
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plot(ivf$gestwks, ivf$bweight, xlab = "x-axis label here", ylab = "y-axis label here")
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We can already see that in terms of summary statistics, Stata can be quite useful, so no hard feelings if you
use Stata in the beginning.

Very Important Information

In RStudio, under one of the panes, you will see a tab for files. Depending on your working directory, you
may see your own files from another project. DO NOT DELETE THESE FILES AS THEY WILL BE
PERMANENTLY DELETED. This happened to a student from a class last semester. . .

There is a lot I have not included because there is simply too much material. If you are ever confused about
a command, type the following:

?plot # this will direct you to a file under the help tab

??plot # a more general search containing the words after '??'

Lastly, there are many resources online, such as stackoverflow or ‘http://www.ats.ucla.edu/stat/r/’, just to
name a few. Professor Nicholas Reich taught a course last semester in R and his website is at this link.
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